Back to Top
Facebook Instagram pinterest RSS
Before You Call for Service...
Spa Care & Maintenance Main Page
Additional Pages:
Electrical Connections
Initial Start Up
Chemical Information
Equipment Care
Spa Covers
Before You Call for Service...

If you are having an issue with you hot tub, see below for some common issues below before requesting a service call.

PROBLEM: Heater Pack does not work at all.

POSSIBLE CAUSE:

  1. Thermostat is turned off.
  2. Timer set to off setting.
  3. Circuit breaker tripped.

SOLUTION:

  1. Turn up the thermostat.
  2. Adjust timer.
  3. Check main panel and reset.

                                                                                                                   

PROBLEM: Reduced water flow and jet action.

POSSIBLE CAUSE:

  1. Clogged filter.
  2. Water level too low.
  3. Partially closed gate valves.

SOLUTION:

  1. Clean filter.
  2. Add water.
  3. Make sure all gate valves are open.

                                                                                                                   

PROBLEM: Pump leaks.

POSSIBLE CAUSE:

  1. Loose unions.
  2. Seal leak. (will leak at pump shaft)

SOLUTION:

  1. Tighten unions at pump.
  2. Replace seal or bring pump to your dealer.

                                                                                                                   

PROBLEM: Pump will not prime. No water coming from jets.

POSSIBLE CAUSE:

  1. Air in filter system.

SOLUTION:

  1. Loosen drain valve and bleed until water comes out.

                                                                                                                   

PROBLEM: Does not heat to proper temperature.

POSSIBLE CAUSE:

  1. Cover left off.
  2. Thermostat set too low and is not reaching desired temperature.
  3. Clogged filter.

SOLUTION:

  1. Always leave cover on when not in use.
  2. Turn up thermostat.
  3. Run spa without filter cartridge. If spa hears to desired temperature, clean filter.

                                                                                                                   

PROBLEM: Equipment pack works but heater does not heat.

POSSIBLE CAUSE:

  1. Thermostat set too low.
  2. Hi-limit tripped.
  3. Clogged filter.

SOLUTION:

  1. Turn up thermostat.
  2. Press reset button.
  3. Clean filter.
  4. Make sure spa is set to heater mode.

                                                                                                                   

PROBLEM: Noisy pump

POSSIBLE CAUSE:

  1. Motor loose on base.

SOLUTION:

  1. Retighten to base.